PSeint: Arreglos o arrays en pseudocódigo

Hola a todos, hoy os explicare como podemos hacer arreglos o arrays en PseInt. Los arreglos o arrays en PseInt son estructuras que almacenan valores del mismo tipo como números o cadenas. Tiene una longitud determinada. Lo primero es declarar su dimensión, indicando el nombre del arreglo o array y su longitud dentro de [].

Veamos un ejemplo:

1
2
3
4
Proceso Prueba
    Definir num como entero;
    Dimension num[5];
FinProceso

Debemos definir num con el tipo de dato que queramos que sea, en este caso numérico, ya que si no al recorrer nos saltará un error.

En los arrays o arreglos empiezan desde 1 y acaban en la longitud que hayamos definido. Si has probado otros lenguajes de programación, sabrás que los arrays empiezan en 0 y acaban en la longitud -1 que hayamos definido. Si es tu caso lo podemos cambiar en las opciones de PseInt, Configurar -> Opciones del Lenguaje -> Personalizar, nos aparecerá lo siguiente:

opciones lenguajes

Elegimos la opción utilizar indices en arreglos y cadenas en base 0.

Nosotros lo dejaremos por defecto, es decir, que empiecen en 1.

Veamos como se asignan valores al array:

1
2
3
4
5
6
7
8
9
Proceso Prueba
      Definir num como entero;
      Dimension num[5];
      num[1]=5;
      num[2]=10;
      num[3]=15;
      num[4]=20;
      num[5]=25;
FinProceso

Como vemos, simplemente debemos indicar el nombre del array, el indice y su valor. Deben estar dentro de la longitud creada, es decir, que en este caso no podríamos asignar un valor al indice 6.

Para recorrer un array, deberemos usar una estructura repetitiva, lo mas recomendable es un Para o Desde donde la variable que declaremos, se insertara en el indice haciendo que en cada repetición varié. Veamos un ejemplo:

1
2
3
4
5
6
7
8
9
10
11
12
Proceso Prueba
      Definir num como entero;
      Dimension num[5];
      num[1]=5;
      num[2]=10;
      num[3]=15;
      num[4]=20;
      num[5]=25;
      Para i<-1 Hasta 5 Con Paso 1 Hacer
         escribir num[i];
      Fin Para
FinProceso

Esta es la salida del ejemplo anterior:

salida array

Ademas de mostrar los valores, también podemos introducirlos por teclado con leer nombre_array[indice] si queremos introducir valores en todos los indices, para ello usaremos un bucle. Veamos un ejemplo:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Proceso Prueba
      Definir num como entero;
      Dimension num[5];
      num[1]=5;
      num[2]=10;
      num[3]=15;
      num[4]=20;
      num[5]=25;
      Para i<-1 Hasta 5 Con Paso 1 Hacer
          leer num[i];
      Fin Para
      Para i<-1 Hasta 5 Con Paso 1 Hacer
          escribir num[i];
      Fin Para
FinProceso

Recuerda que podemos hacer lo que queramos con lo valores del array o arreglo, como sumar sus valores, hacer una media, etc.

Por último, si has probado otros lenguajes de programación sabrás que se puede saber el tamaño de un array o arreglo, con un método. En pseudocódigo esto no existe, pero si podemos hacer para ello, podemos usar una constante para indicar el tamaño. La mayor ventaja es que si cambiamos el tamaño de un array o arreglo, solo deberemos cambiar en un lugar y no en todos.

Veamos un ejemplo:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Proceso Prueba
      Definir num como entero;
      TAMANIO=5;
      Dimension num[TAMANIO];
      num[1]=5;
      num[2]=10;
      num[3]=15;
      num[4]=20;
      num[5]=25;
      Para i<-1 Hasta TAMANIO Con Paso 1 Hacer
          Escribir "Escribe un valor para el indice ",i;
          leer num[i];
      Fin Para
      Para i<-1 Hasta TAMANIO Con Paso 1 Hacer
          escribir num[i];
      Fin Para
FinProceso

NOTA: uso TAMANIO en lugar de TAMAÑO porque PseInt no acepta el carácter ñ.

Espero que os sea de ayuda. Si tenéis dudas, preguntad. Estamos para ayudarte.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *