EJERCICIO21

Algoritmo ejercc21
definir op,n,s,f,i como entero
s=1
i=1
f=1

Repetir

escribir “**MENU**”
Escribir ” 1.SALIR”
Escribir ” 2.SUMATORIA”
Escribir ” 3.FACTORIAL”
Escribir ” ”
Escribir “ELIGA UNA OPCION”
LEER op
ESCRIBIR ” ”
Segun op Hacer
1:
Escribir “Gracias”
2:
Escribir “SUMATORIA”
escribir “Ingrese el numero para calcular la suma”
leer n
s=n+n
escribir n “+” n “=” s

Escribir ” ”
3:
Escribir “FACTORIAL”
Escribir “ingrese un numero”
leer n

Mientras i<=n hacer

f=f*i
i=i+1

FinMientras
escribir”SU FACTORIAL ES ” f
Escribir ” ”
De Otro Modo:
escribir “op no valida”
Escribir ” ”
Fin Segun
Hasta Que op=1
FinAlgoritmo

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *