PSeint: Arreglos o arrays en pseudocódigo

Hola a todos, hoy os explicare como podemos hacer arreglos o arrays en PseInt. Los arreglos o arrays en PseInt son estructuras que almacenan valores del mismo tipo como números o cadenas. Tiene una longitud determinada. Lo primero es declarar su dimensión, indicando el nombre del arreglo o array y su longitud dentro de [].

Veamos un ejemplo:

EJERCICIO 6

Algoritmo ejercc6
Escribir “INGRESE VARIOS NUMEROS ENTEROS”
LEER num
SUMA<-0;
Mientras num<>0 Hacer
LEER NUM
SUMA <-SUMA+num
Fin Mientras
Escribir”La suma de los numeros ingresados es”,SUMA
FinAlgoritmo read more

EJERCICIO 4

Algoritmo ejerc4
Escribir “INGRESE NUMEROS ENTEROS CON EL CERO SE DETIENE”
Leer num
Mientras num<>0 Hacer
leer num
Fin Mientras
FinAlgoritmo

Ejercicios de Programacion – Parte 2

Ejercicio 11

Programa que lea un número entero por teclado y que calcule su factorial

Ejercicio 12

Escribir un programa que lea números enteros indefinidamente hasta que llegue el número 0

Ejercicio 13

Programa que lea una serie de números por teclado e indique cuál es el mayor hasta que ingrese 0 read more

Ingresar saludo

Algoritmo SALUDO
Escribir “HOLA MUNDO”
Escribir “JESENIA”
Escribir “26 ANOS”
FinAlgoritmo

En este programa lo que se hizo es presentar por pantalla palabras entre comillas. read more

ejercicio 2

Se pide ingresar un numero y saber si es par o no.

Algoritmo ejercc2
Escribir “Ingrese el numero”
Leer num;
reserva<-num% 2 — en esta condicion se usa dos variables y una constante donde hacemos una divison para 2 donde usamos el signo operacional % para saber el valor del residuo
Si reserva=0 Entonces  –en  esta condicion es saber si el residuo q se va a llamar reserva es saber si es exacta o inexacta (par o impar)
Escribir “Numero es par”
Sino
Escribir “Numero no es ”
Fin Si
FinAlgoritmo read more

ejercicio 3

Algoritmo mayor

Usaremos dos condiciones en la primera se preguntara si a es mayor b y c y se mostrara si a es mayor si no en caso contrario daremos otra condicion para ir haciendo un barrido de cual de los tres es mayor donde se pregunta si b es mayor a y c donde se presentara por pantalla el valor de b si no se presentara el ultimo numero ingresado que es c
Escribir “ingrese tres numeros”
Leer a
Leer b
Leer c
Si a>b Y a>c Entonces –En esta condicion usaremos op logicas  Y donde si a es mayor b y a mayor c
Escribir “numero mayor es” a
Sino
Si b>a Y b>c
Escribir “numero mayor es” b
Sino
Escribir “numero mayor es” c
Fin Si
Fin Si
FinAlgoritmo read more

EJERCICIO UNO

En este pequeno ejercicio se realizo el ingreso de dos numeros y saber cual es el mayor y dar la suma de ambos numeros. Se aplico la instruccion SI, donde se le pregunta si a es mayor b y se muestra por pantalla el numero mayor termina la condicion luego se hace la suma de esos dos donde se guarda el resultado en otra variable que sera presentado por pantalla. read more

EJERCICIO 5

En este programa utilizaremos una nueva funcion que es PARA donde asignaremos una variable que es  i donde comenzara a contar desde 1 y este proceso se repitara hasta que esta variable tenga el valor de 8 y fuera de esta funcion presentaremos la suma de los numeros ingresados. read more